USE_SERIAL not working on 230X in eeprom_build

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

USE_SERIAL not working on 230X in eeprom_build

Robert Cox

From 15d74c57f4ffede7b53df2dc7dd729c5e0264089 Mon Sep 17 00:00:00 2001
From: novatech <[hidden email]>
Date: Wed, 14 Dec 2016 09:06:49 -0600
Subject: [PATCH 1/2] Found that the USE_SERIAL was not being set correctly in
 the eeprom_build routine for the 230X. Tracked the problem down to a line
 that hard coded the value when the 230X was first added. With this line
 removed code currently in the code before the switch will set the bit
 correctly for the 230X.

---
 src/ftdi.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/src/ftdi.c b/src/ftdi.c
index 0b26a7a..b87aa1c 100644
--- a/src/ftdi.c
+++ b/src/ftdi.c
@@ -3181,7 +3181,6 @@ int ftdi_eeprom_build(struct ftdi_context *ftdi)
             break;
         case TYPE_230X:
             output[0x00] = 0x80; /* Actually, leave the default value */
-            output[0x0a] = 0x08; /* Enable USB Serial Number */
             /*FIXME: Make DBUS & CBUS Control configurable*/
             output[0x0c] = 0;    /* DBUS drive 4mA, CBUS drive 4 mA like factory default */
             for (j = 0; j <= 6; j++)
-- 
2.4.11




libftdi - see http://www.intra2net.com/en/developer/libftdi for details.
To unsubscribe send a mail to [hidden email]


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: USE_SERIAL not working on 230X in eeprom_build

Thomas Jarosch
Hi Robert,

On Wednesday, 14. December 2016 15:47:41 Robert Cox wrote:
> From 15d74c57f4ffede7b53df2dc7dd729c5e0264089 Mon Sep 17 00:00:00 2001
> From: novatech <[hidden email]>
> Date: Wed, 14 Dec 2016 09:06:49 -0600
> Subject: [PATCH 1/2] Found that the USE_SERIAL was not being set correctly
> in the eeprom_build routine for the 230X. Tracked the problem down to a
> line that hard coded the value when the 230X was first added. With this
> line removed code currently in the code before the switch will set the
> bit correctly for the 230X.

your analysis is correct, thanks for the patch.
I had to apply it manually as the message got mangled
and "<[hidden email]>" wasn't a proper email address.

Also I've applied your docu patch manually. While doing this
I've changed "Yum" to "yum" since the command is written in lower case.

Starting with Fedora 22+, dnf replaces yum. So we probably
need to update this in the future, too :)

Cheers,
Thomas


--
libftdi - see http://www.intra2net.com/en/developer/libftdi for details.
To unsubscribe send a mail to [hidden email]  

Loading...